CVE-2017-14062

NameCVE-2017-14062
DescriptionInteger overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1084-1, DLA-1085-1, DSA-3988-1
NVD severityhigh (attack range: remote)
Debian Bugs873902, 873903

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libidn (PTS)wheezy1.25-2vulnerable
wheezy (security)1.25-2+deb7u3fixed
jessie (security), jessie1.29-1+deb8u2vulnerable
stretch1.33-1vulnerable
buster, sid1.33-2fixed
libidn2-0 (PTS)wheezy0.8-2vulnerable
wheezy (security)0.8-2+deb7u1fixed
jessie0.10-2vulnerable
jessie (security)0.10-2+deb8u1fixed
stretch (security), stretch0.16-1+deb9u1fixed
buster, sid2.0.2-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libidnsource(unstable)1.33-2high873903
libidnsourcewheezy1.25-2+deb7u3highDLA-1084-1
libidn2-0source(unstable)2.0.2-4high873902
libidn2-0sourcejessie0.10-2+deb8u1highDSA-3988-1
libidn2-0sourcestretch0.16-1+deb9u1highDSA-3988-1
libidn2-0sourcewheezy0.8-2+deb7u1highDLA-1085-1

Notes

https://gitlab.com/libidn/libidn2/commit/3284eb342cd0ed1a18786e3fcdf0cdd7e76676bd

Search for package or bug name: Reporting problems