CVE-2017-14100

NameCVE-2017-14100
DescriptionIn Asterisk 11.x before 11.25.2, 13.x before 13.17.1, and 14.x before 14.6.1 and Certified Asterisk 11.x before 11.6-cert17 and 13.x before 13.13-cert5, unauthorized command execution is possible. The app_minivm module has an "externnotify" program configuration option that is executed by the MinivmNotify dialplan application. The application uses the caller-id name and number as part of a built string passed to the OS shell for interpretation and execution. Since the caller-id name and number can come from an untrusted source, a crafted caller-id name or number allows an arbitrary shell command injection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3964-1
NVD severityhigh (attack range: remote)
Debian Bugs873908

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)wheezy1:1.8.13.1~dfsg1-3+deb7u3vulnerable
wheezy (security)1:1.8.13.1~dfsg1-3+deb7u6vulnerable
jessie1:11.13.1~dfsg-2+deb8u2vulnerable
jessie (security)1:11.13.1~dfsg-2+deb8u3fixed
stretch1:13.14.1~dfsg-2vulnerable
stretch (security)1:13.14.1~dfsg-2+deb9u1fixed
buster1:13.17.1~dfsg-1fixed
sid1:13.17.2~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksource(unstable)1:13.17.1~dfsg-1high873908
asterisksourcejessie1:11.13.1~dfsg-2+deb8u3highDSA-3964-1
asterisksourcestretch1:13.14.1~dfsg-2+deb9u1highDSA-3964-1

Notes

https://issues.asterisk.org/jira/browse/ASTERISK-27103
Fix: https://gerrit.asterisk.org/#/q/topic:ASTERISK-27103

Search for package or bug name: Reporting problems