CVE-2017-14108

NameCVE-2017-14108
Descriptionlibgedit.a in GNOME gedit through 3.22.1 allows remote attackers to cause a denial of service (CPU consumption) via a file that begins with many '\0' characters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs875311

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gedit (PTS)wheezy3.4.2-1vulnerable
jessie3.14.0-3vulnerable
stretch3.22.0-2vulnerable
buster, sid3.22.1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
geditsource(unstable)(unfixed)unimportant875311

Notes

negligible security impact

Search for package or bug name: Reporting problems