CVE-2017-14226

NameCVE-2017-14226
DescriptionWP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs876001

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libwpd (PTS)wheezy0.9.4-3fixed
jessie0.10.0-2+deb8u1fixed
stretch0.10.1-5+deb9u1fixed
buster, sid0.10.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwpdsource(unstable)0.10.2-1medium876001
libwpdsourcejessie0.10.0-2+deb8u1medium
libwpdsourcestretch0.10.1-5+deb9u1medium
libwpdsourcewheezy(not affected)

Notes

[wheezy] - libwpd <not-affected> (Vulnerable code do not exist)
https://bugs.documentfoundation.org/show_bug.cgi?id=112269
https://sourceforge.net/p/libwpd/code/ci/0329a9c57f9b3b0efa0f09a5235dfd90236803a5/
https://sourceforge.net/p/libwpd/code/ci/f40827b3eae260ce657c67d9fecc855b09dea3c3/

Search for package or bug name: Reporting problems