CVE-2017-14348

NameCVE-2017-14348
DescriptionLibRaw before 0.18.4 has a heap-based Buffer Overflow in the processCanonCameraInfo function via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)wheezy0.14.6-2+deb7u1fixed
wheezy (security)0.14.6-2+deb7u3fixed
jessie (security), jessie0.16.0-9+deb8u3fixed
stretch (security), stretch0.17.2-6+deb9u1vulnerable
buster, sid0.18.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsource(unstable)0.18.5-1medium
librawsourcejessie(not affected)
librawsourcewheezy(not affected)

Notes

[stretch] - libraw <no-dsa> (Minor issue)
[jessie] - libraw <not-affected> (Vulnerable code not present)
[wheezy] - libraw <not-affected> (Vulnerable code not present)
https://github.com/LibRaw/LibRaw/issues/100
https://github.com/LibRaw/LibRaw/commit/8303e74b0567806dd5f16fc39aab70fe928de1a2

Search for package or bug name: Reporting problems