CVE-2017-14493

NameCVE-2017-14493
DescriptionStack-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted DHCPv6 request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3989-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dnsmasq (PTS)wheezy2.62-3+deb7u3fixed
wheezy (security)2.62-3+deb7u4fixed
jessie2.72-3+deb8u1vulnerable
jessie (security)2.72-3+deb8u2fixed
stretch2.76-5vulnerable
stretch (security)2.76-5+deb9u1fixed
buster, sid2.78-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dnsmasqsource(unstable)2.78-1high
dnsmasqsourcejessie2.72-3+deb8u2highDSA-3989-1
dnsmasqsourcestretch2.76-5+deb9u1highDSA-3989-1
dnsmasqsourcewheezy(not affected)

Notes

[wheezy] - dnsmasq <not-affected> (Vulnerable code introduced later)
https://security.googleblog.com/2017/10/behind-masq-yet-more-dns-and-dhcp.html
http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=3d4ff1ba8419546490b464418223132529514033

Search for package or bug name: Reporting problems