CVE-2017-14518

NameCVE-2017-14518
DescriptionIn Poppler 0.59.0, a floating point exception exists in the isImageInterpolationRequired() function in Splash.cc via a crafted PDF document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4079-1
NVD severitymedium (attack range: remote)
Debian Bugs876082

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)wheezy0.18.4-6fixed
wheezy (security)0.18.4-6+deb7u5fixed
jessie0.26.5-2+deb8u1vulnerable
jessie (security)0.26.5-2+deb8u2fixed
stretch0.48.0-2vulnerable
stretch (security)0.48.0-2+deb9u1fixed
buster, sid0.61.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.61.1-2low876082
popplersourcejessie0.26.5-2+deb8u2mediumDSA-4079-1
popplersourcestretch0.48.0-2+deb9u1mediumDSA-4079-1
popplersourcewheezy(not affected)

Notes

[wheezy] - poppler <not-affected> (vulnerable code not present)
https://bugs.freedesktop.org/show_bug.cgi?id=102688
https://cgit.freedesktop.org/poppler/poppler/commit/?id=80f9819b6233f9f9b5fd44f0e4cad026e5d048c2

Search for package or bug name: Reporting problems