CVE-2017-14723

NameCVE-2017-14723
DescriptionBefore version 4.8.2, WordPress mishandled % characters and additional placeholder values in $wpdb->prepare, and thus did not properly address the possibility of plugins and themes enabling SQL injection attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1151-1, DSA-3997-1
NVD severityhigh (attack range: remote)
Debian Bugs876274

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17fixed
jessie (security)4.1+dfsg-1+deb8u18fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u4fixed
buster, sid4.9.8+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.8.2+dfsg-1high876274
wordpresssourcejessie4.1+dfsg-1+deb8u15highDSA-3997-1
wordpresssourcestretch4.7.5+dfsg-2+deb9u1highDSA-3997-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u17highDLA-1151-1

Notes

https://core.trac.wordpress.org/changeset/41470
https://core.trac.wordpress.org/changeset/41496
https://github.com/WordPress/WordPress/commit/70b21279098fc973eae803693c0705a548128e48
https://github.com/WordPress/WordPress/commit/fc930d3daed1c3acef010d04acc2c5de93cd18ec
https://medium.com/websec/wordpress-sqli-bbb2afcc8e94
https://medium.com/websec/wordpress-sqli-poc-f1827c20bf8e

Search for package or bug name: Reporting problems