CVE-2017-14726

NameCVE-2017-14726
DescriptionBefore version 4.8.2, WordPress was vulnerable to a cross-site scripting attack via shortcodes in the TinyMCE visual editor.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3997-1
NVD severitymedium (attack range: remote)
Debian Bugs876274

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17fixed
jessie (security)4.1+dfsg-1+deb8u18fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u4fixed
buster, sid4.9.8+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.8.2+dfsg-1medium876274
wordpresssourcejessie4.1+dfsg-1+deb8u15mediumDSA-3997-1
wordpresssourcestretch4.7.5+dfsg-2+deb9u1mediumDSA-3997-1
wordpresssourcewheezy(not affected)

Notes

[wheezy] - wordpress <not-affected> (Vulnerable code not present)
https://core.trac.wordpress.org/changeset/41395

Search for package or bug name: Reporting problems