CVE-2017-14867

NameCVE-2017-14867
DescriptionGit before 2.10.5, 2.11.x before 2.11.4, 2.12.x before 2.12.5, 2.13.x before 2.13.6, and 2.14.x before 2.14.2 uses unsafe Perl scripts to support subcommands such as cvsserver, which allows attackers to execute arbitrary OS commands via shell metacharacters in a module name. The vulnerable code is reachable via git-shell even without CVS support.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1120-1, DSA-3984-1
NVD severityhigh (attack range: remote)
Debian Bugs876854

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
git (PTS)wheezy1:1.7.10.4-1+wheezy3vulnerable
wheezy (security)1:1.7.10.4-1+wheezy6fixed
jessie1:2.1.4-2.1+deb8u3vulnerable
jessie (security)1:2.1.4-2.1+deb8u5fixed
stretch (security), stretch1:2.11.0-3+deb9u2fixed
buster1:2.14.2-1fixed
sid1:2.15.0~rc1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitsource(unstable)1:2.14.2-1high876854
gitsourcejessie1:2.1.4-2.1+deb8u5highDSA-3984-1
gitsourcestretch1:2.11.0-3+deb9u2highDSA-3984-1
gitsourcewheezy1:1.7.10.4-1+wheezy6highDLA-1120-1

Notes

http://www.openwall.com/lists/oss-security/2017/09/26/9
https://public-inbox.org/git/xmqqy3p29ekj.fsf@gitster.mtv.corp.google.com/T/#u

Search for package or bug name: Reporting problems