CVE-2017-14990

NameCVE-2017-14990
DescriptionWordPress 4.8.2 stores cleartext wp_signups.activation_key values (but stores the analogous wp_users.user_activation_key values as hashes), which might make it easier for remote attackers to hijack unactivated user accounts by leveraging database read access (such as access gained through an unspecified SQL injection vulnerability).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3997-1
NVD severitymedium (attack range: remote)
Debian Bugs877629

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17fixed
jessie (security)4.1+dfsg-1+deb8u18fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u4fixed
buster, sid4.9.8+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.8.2+dfsg-2medium877629
wordpresssourcejessie4.1+dfsg-1+deb8u15mediumDSA-3997-1
wordpresssourcestretch4.7.5+dfsg-2+deb9u1mediumDSA-3997-1

Notes

[wheezy] - wordpress <ignored> (Fix requires database upgrade which is too intrusive compared to the actual benefit.)
https://core.trac.wordpress.org/ticket/38474

Search for package or bug name: Reporting problems