CVE-2017-15108

NameCVE-2017-15108
Descriptionspice-vdagent up to and including 0.17.0 does not properly escape save directory before passing to shell, allowing local attacker with access to the session the agent runs in to inject arbitrary commands to be executed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2524-1
Debian Bugs883238

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spice-vdagent (PTS)buster0.18.0-1fixed
bullseye0.20.0-2fixed
bookworm, sid0.22.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spice-vdagentsourcewheezy(not affected)
spice-vdagentsourcestretch0.17.0-1+deb9u1DLA-2524-1
spice-vdagentsource(unstable)0.18.0-1883238

Notes

[jessie] - spice-vdagent <no-dsa> (Minor issue)
[wheezy] - spice-vdagent <not-affected> (Vulnerable code not present)
Fixed by: https://cgit.freedesktop.org/spice/linux/vd_agent/commit/?id=8ba174816d245757e743e636df357910e1d5eb61
https://bugzilla.redhat.com/show_bug.cgi?id=1510864

Search for package or bug name: Reporting problems