CVE-2017-15298

NameCVE-2017-15298
DescriptionGit through 2.14.2 mishandles layers of tree objects, which allows remote attackers to cause a denial of service (memory consumption) via a crafted repository, aka a Git bomb. This can also have an impact of disk consumption; however, an affected process typically would not survive its attempt to build the data structure in memory before writing to disk.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
git (PTS)wheezy1:1.7.10.4-1+wheezy3vulnerable
wheezy (security)1:1.7.10.4-1+wheezy6vulnerable
jessie (security), jessie1:2.1.4-2.1+deb8u5vulnerable
stretch (security), stretch1:2.11.0-3+deb9u2vulnerable
buster, sid1:2.17.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitsource(unstable)(unfixed)unimportant

Notes

https://kate.io/blog/git-bomb/
https://github.com/Katee/git-bomb
No practical security implications

Search for package or bug name: Reporting problems