CVE-2017-15400

NameCVE-2017-15400
DescriptionInsufficient restriction of IPP filters in CUPS in Google Chrome OS prior to 62.0.3202.74 allowed a remote attacker to execute a command with the same privileges as the cups daemon via a crafted PPD file, aka a printer zeroconfig CRLF issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4243-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)jessie1.7.5-11+deb8u2fixed
jessie (security)1.7.5-11+deb8u4fixed
stretch2.2.1-8+deb9u1vulnerable
stretch (security)2.2.1-8+deb9u2fixed
buster, sid2.2.8-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)2.2.3-2high
cupssourcejessie(not affected)
cupssourcestretch2.2.1-8+deb9u2highDSA-4243-1
cupssourcewheezy(not affected)

Notes

[jessie] - cups <not-affected> (Vulnerable code not present, ppdCreateFromIPP() introduced in v2.2.0)
[wheezy] - cups <not-affected> (Vulnerable code not present)
https://bugs.chromium.org/p/chromium/issues/detail?id=777215
Patches from upstream to restrict what filters will be accpeted
https://github.com/apple/cups/commit/07428f6a640ff93aa0b4cc69ca372e2cf8490e41 (v2.2.2)
https://github.com/apple/cups/commit/1add23375658e9163e5493ee19de7c9f7a9b483b (v2.2.2)

Search for package or bug name: Reporting problems