CVE-2017-15566

NameCVE-2017-15566
DescriptionInsecure SPANK environment variable handling exists in SchedMD Slurm before 16.05.11, 17.x before 17.02.9, and 17.11.x before 17.11.0rc2, allowing privilege escalation to root during Prolog or Epilog execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4023-1
NVD severityhigh
Debian Bugs880530

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)stretch16.05.9-1+deb9u4fixed
stretch (security)16.05.9-1+deb9u2fixed
buster, buster (security)18.08.5.2-1+deb10u1fixed
bullseye, sid19.05.5-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsourcewheezy(not affected)
slurm-llnlsourcejessie(not affected)
slurm-llnlsourcestretch16.05.9-1+deb9u1DSA-4023-1
slurm-llnlsource(unstable)17.02.9-1880530

Notes

[jessie] - slurm-llnl <not-affected> (Vulnerable code introduced later)
[wheezy] - slurm-llnl <not-affected> (Vulnerable code introduced later)
https://bugs.schedmd.com/show_bug.cgi?id=4228 (not public)
Fixed by: https://github.com/SchedMD/slurm/commit/b30e9e9ee2ade6951bfaf28e15ef77325a206971

Search for package or bug name: Reporting problems