CVE-2017-15723

NameCVE-2017-15723
DescriptionIn Irssi before 1.0.5, overlong nicks or targets may result in a NULL pointer dereference while splitting the message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4016-1
NVD severitymedium
Debian Bugs879521

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)stretch (security), stretch1.0.7-1~deb9u1fixed
buster1.2.0-2fixed
bullseye, sid1.2.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisourcewheezy(not affected)
irssisourcejessie0.8.17-1+deb8u5DSA-4016-1
irssisourcestretch1.0.2-1+deb9u3DSA-4016-1
irssisource(unstable)1.0.5-1879521

Notes

[wheezy] - irssi <not-affected> (Vulnerable code introduced in 0.8.17)
https://irssi.org/security/irssi_sa_2017_10.txt
https://github.com/irssi/irssi/commit/43e44d553d44e313003cee87e6ea5e24d68b84a1

Search for package or bug name: Reporting problems