CVE-2017-15914

NameCVE-2017-15914
DescriptionIncorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
borgbackup (PTS)bullseye1.1.16-3fixed
bookworm1.2.4-1fixed
sid, trixie1.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
borgbackupsourcestretch(not affected)
borgbackupsource(unstable)1.1.3-1

Notes

[stretch] - borgbackup <not-affected> (Only affects 1.1.0, 1.1.1 and 1.1.2 releases)
https://borgbackup.readthedocs.io/en/stable/changes.html#version-1-1-3-2017-11-27

Search for package or bug name: Reporting problems