CVE-2017-15923

NameCVE-2017-15923
DescriptionKonversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1174-1, DSA-4033-1
Debian Bugs881586

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
konversation (PTS)wheezy1.4-1+deb7u1vulnerable
wheezy (security)1.4-1+deb7u2fixed
jessie1.5-2vulnerable
jessie (security)1.5-2+deb8u1fixed
stretch1.6.2-2vulnerable
stretch (security)1.6.2-2+deb9u1fixed
buster1.7.3-1fixed
sid1.7.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
konversationsource(unstable)1.7.3-1881586
konversationsourcejessie1.5-2+deb8u1DSA-4033-1
konversationsourcestretch1.6.2-2+deb9u1DSA-4033-1
konversationsourcewheezy1.4-1+deb7u2DLA-1174-1

Notes

https://cgit.kde.org/konversation.git/commit/?h=1.7&id=6a7f59ee1b9dbc6e5cf9e5f3b306504d02b73ef0

Search for package or bug name: Reporting problems