CVE-2017-16114

NameCVE-2017-16114
DescriptionThe marked module is vulnerable to a regular expression denial of service. Based on the information published in the public issue, 1k characters can block for around 6 seconds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-marked (PTS)stretch0.3.6+dfsg-1vulnerable
buster0.5.1+dfsg-1fixed
bullseye0.8.0+ds+repack-2fixed
bookworm4.0.16+ds+~4.0.3-1fixed
sid4.0.17+ds+~4.0.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-markedsource(unstable)0.3.9+dfsg-1unimportant

Notes

https://nodesecurity.io/advisories/531

Search for package or bug name: Reporting problems