CVE-2017-16669

NameCVE-2017-16669
Descriptioncoders/wpg.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file, related to the AcquireCacheNexus function in magick/pixel_cache.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1168-1
NVD severitymedium (attack range: remote)
Debian Bugs881391

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)wheezy1.3.16-1.1vulnerable
wheezy (security)1.3.16-1.1+deb7u19fixed
jessie1.3.20-3+deb8u1vulnerable
jessie (security)1.3.20-3+deb8u2vulnerable
stretch1.3.25-8vulnerable
buster, sid1.3.28-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.26-19medium881391
graphicsmagicksourcewheezy1.3.16-1.1+deb7u14mediumDLA-1168-1

Notes

https://sourceforge.net/p/graphicsmagick/bugs/450/
http://hg.code.sf.net/p/graphicsmagick/code/rev/135bdcb88b8d
http://hg.code.sf.net/p/graphicsmagick/code/rev/1b9e64a8901e
http://hg.code.sf.net/p/graphicsmagick/code/rev/2a21cda3145b
http://hg.code.sf.net/p/graphicsmagick/code/rev/2b7c826d36af
http://hg.code.sf.net/p/graphicsmagick/code/rev/3dc7b4e3779d
http://hg.code.sf.net/p/graphicsmagick/code/rev/75245a215fff
http://hg.code.sf.net/p/graphicsmagick/code/rev/e8086faa52d0
http://hg.code.sf.net/p/graphicsmagick/code/rev/fcd3ed3394f6

Search for package or bug name: Reporting problems