CVE-2017-16872

NameCVE-2017-16872
DescriptionAn issue was discovered in Teluu pjproject (pjlib and pjlib-util) in PJSIP before 2.7.1. Parsing the numeric header fields in a SIP message (like cseq, ttl, port, etc.) all had the potential to overflow, either causing unintended values to be captured or, if the values were subsequently converted back to strings, a buffer overrun. This will lead to a potential exploit using carefully crafted invalid values.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pjproject (PTS)jessie (security), jessie2.1.0.0.ast20130823-1+deb8u1vulnerable
stretch2.5.5~dfsg-6vulnerable
buster, sid2.7.1~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pjprojectsource(unstable)2.7.1~dfsg-1high

Notes

https://trac.pjsip.org/repos/ticket/2056
https://trac.pjsip.org/repos/changeset/5682

Search for package or bug name: Reporting problems