CVE-2017-17432

NameCVE-2017-17432
DescriptionOpenAFS 1.x before 1.6.22 does not properly validate Rx ack packets, which allows remote attackers to cause a denial of service (system crash or application crash) via crafted fields, as demonstrated by an integer underflow and assertion failure for a small MTU value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1213-1, DSA-4067-1
NVD severityhigh (attack range: remote)
Debian Bugs883602

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openafs (PTS)jessie1.6.9-2+deb8u7fixed
jessie (security)1.6.9-2+deb8u8fixed
stretch (security), stretch1.6.20-2+deb9u2fixed
buster, sid1.8.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openafssource(unstable)1.6.22-1high883602
openafssourcejessie1.6.9-2+deb8u6highDSA-4067-1
openafssourcestretch1.6.20-2+deb9u1highDSA-4067-1
openafssourcewheezy1.6.1-3+deb7u8highDLA-1213-1

Notes

https://www.openafs.org/pages/security/OPENAFS-SA-2017-001.txt

Search for package or bug name: Reporting problems