CVE-2017-17458

NameCVE-2017-17458
DescriptionIn Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repository. Typical use of Mercurial prevents construction of such repositories, but they can be created programmatically.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1224-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)jessie (security), jessie3.1.2-2+deb8u4vulnerable
stretch (security), stretch4.0-1+deb9u1vulnerable
buster, sid4.6.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsource(unstable)4.4.1-1high
mercurialsourcewheezy2.2.2-4+deb7u6highDLA-1224-1

Notes

https://bz.mercurial-scm.org/show_bug.cgi?id=5730
https://www.mercurial-scm.org/pipermail/mercurial-devel/2017-November/107333.html
https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.4.1_.282017-11-07.29
Fixed by: https://mercurial-scm.org/repo/hg/rev/071cbeba4212
Alternative workaround: https://mercurial-scm.org/repo/hg/rev/5e27afeddaee

Search for package or bug name: Reporting problems