CVE-2017-17498

NameCVE-2017-17498
DescriptionWritePNMImage in coders/pnm.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (bit_stream.c MagickBitStreamMSBWrite heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1231-1, DLA-1401-1, DSA-4321-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2vulnerable
jessie (security)1.3.20-3+deb8u4fixed
stretch1.3.25-8vulnerable
stretch (security)1.3.30+hg15796-1~deb9u1fixed
buster, sid1.3.30+hg15796-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.27-1medium
graphicsmagicksourcejessie1.3.20-3+deb8u3mediumDLA-1401-1
graphicsmagicksourcestretch1.3.30+hg15796-1~deb9u1mediumDSA-4321-1
graphicsmagicksourcewheezy1.3.16-1.1+deb7u16mediumDLA-1231-1

Notes

http://hg.code.sf.net/p/graphicsmagick/code/rev/f1c418ef0260
https://sourceforge.net/p/graphicsmagick/bugs/525/

Search for package or bug name: Reporting problems