CVE-2017-17501

NameCVE-2017-17501
DescriptionWriteOnePNGImage in coders/png.c in GraphicsMagick 1.3.26 has a heap-based buffer over-read via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1231-1, DLA-1401-1, DSA-4321-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2vulnerable
jessie (security)1.3.20-3+deb8u10fixed
stretch1.3.30+hg15796-1~deb9u2fixed
stretch (security)1.3.30+hg15796-1~deb9u4fixed
buster1.4~hg15978-1+deb10u1fixed
buster (security)1.4+really1.3.35-1~deb10u1fixed
bullseye1.4+really1.3.35-1fixed
sid1.4+really1.3.35-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.27-1
graphicsmagicksourcejessie1.3.20-3+deb8u3DLA-1401-1
graphicsmagicksourcestretch1.3.30+hg15796-1~deb9u1DSA-4321-1
graphicsmagicksourcewheezy1.3.16-1.1+deb7u16DLA-1231-1

Notes

http://hg.code.sf.net/p/graphicsmagick/code/rev/5b8414c0d0c4
https://sourceforge.net/p/graphicsmagick/bugs/526/

Search for package or bug name: Reporting problems