CVE-2017-17531

NameCVE-2017-17531
Descriptiongozilla.c in GNU GLOBAL 4.8.6 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs884912

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
global (PTS)wheezy, jessie5.7.1-2vulnerable
stretch6.5.6-2vulnerable
buster, sid6.6.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
globalsource(unstable)6.6.1-1unimportant884912

Notes

https://sources.debian.org/src/global/4.8.6-2/gozilla/gozilla.c/#L269

Search for package or bug name: Reporting problems