CVE-2017-17718

NameCVE-2017-17718
DescriptionThe Net::LDAP (aka net-ldap) gem before 0.16.0 for Ruby has Missing SSL Certificate Validation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs884693

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-net-ldap (PTS)wheezy0.3.1-2vulnerable
jessie0.8.0-1fixed
buster, sid, stretch0.12.1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-net-ldapsource(unstable)(unfixed)medium884693
ruby-net-ldapsourcejessie(not affected)

Notes

[stretch] - ruby-net-ldap <no-dsa> (Minor issue)
[jessie] - ruby-net-ldap <not-affected> (Documentation already states that there is no validation)
[wheezy] - ruby-net-ldap <ignored> (Doc always said that there is no validation)
https://github.com/ruby-ldap/ruby-net-ldap/issues/258
Versions < 0.10 properly acknowledge in their documentation the lack of any SSL
validation, see https://sources.debian.org/src/ruby-net-ldap/0.8.0-1/lib/net/ldap.rb/#L476
In wheezy/jessie, only reverse dependencies are redmine (which is unsupported in wheezy)
and ruby-omniauth-ldap (which has no reverse dep either).

Search for package or bug name: Reporting problems