CVE-2017-17786

NameCVE-2017-17786
DescriptionIn GIMP 2.8.22, there is a heap-based buffer over-read in ReadImage in plug-ins/common/file-tga.c (related to bgr2rgb.part.1) via an unexpected bits-per-pixel value for an RGBA image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1220-1, DSA-4077-1
NVD severitymedium (attack range: remote)
Debian Bugs884862

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gimp (PTS)jessie (security), jessie2.8.14-1+deb8u2fixed
stretch (security), stretch2.8.18-1+deb9u1fixed
buster, sid2.10.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gimpsource(unstable)2.8.20-1.1unimportant884862
gimpsourcejessie2.8.14-1+deb8u2mediumDSA-4077-1
gimpsourcestretch2.8.18-1+deb9u1mediumDSA-4077-1
gimpsourcewheezy2.8.2-2+deb7u3mediumDLA-1220-1

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=739134
https://git.gnome.org/browse/gimp/commit/?id=674b62ad45b6579ec6d7923dc3cb1ef4e8b5498b (master)
https://git.gnome.org/browse/gimp/commit/?id=8ea316667c8a3296bce2832b3986b58d0fdfc077 (master)
https://git.gnome.org/browse/gimp/commit/?h=gimp-2-8&id=ef9c821fff8b637a2178eab1c78cae6764c50e12 (gimp-2-8)
https://git.gnome.org/browse/gimp/commit/?h=gimp-2-8&id=22e2571c25425f225abdb11a566cc281fca6f366 (gimp-2-8)
Crash in desktop tool, no/negligible security impact

Search for package or bug name: Reporting problems