CVE-2017-17787

NameCVE-2017-17787
DescriptionIn GIMP 2.8.22, there is a heap-based buffer over-read in read_creator_block in plug-ins/common/file-psp.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1220-1, DSA-4077-1
NVD severitymedium (attack range: remote)
Debian Bugs884927

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gimp (PTS)wheezy2.8.2-2+deb7u1vulnerable
wheezy (security)2.8.2-2+deb7u3fixed
jessie2.8.14-1+deb8u1vulnerable
jessie (security)2.8.14-1+deb8u2fixed
stretch (security), stretch2.8.18-1+deb9u1fixed
buster, sid2.8.22-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gimpsource(unstable)2.8.20-1.1unimportant884927
gimpsourcejessie2.8.14-1+deb8u2mediumDSA-4077-1
gimpsourcestretch2.8.18-1+deb9u1mediumDSA-4077-1
gimpsourcewheezy2.8.2-2+deb7u3mediumDLA-1220-1

Notes

https://git.gnome.org/browse/GIMP/commit/?id=eb2980683e6472aff35a3117587c4f814515c74d (master)
https://git.gnome.org/browse/GIMP/commit/?id=87ba505fff85989af795f4ab6a047713f4d9381d (gimp-2-8)
https://bugzilla.gnome.org/show_bug.cgi?id=790853
Crash in desktop tool, no/negligable security impact

Search for package or bug name: Reporting problems