CVE-2017-17790

NameCVE-2017-17790
DescriptionThe lazy_initialize function in lib/resolv.rb in Ruby through 2.4.3 uses Kernel#open, which might allow Command Injection attacks, as demonstrated by a Resolv::Hosts::new argument beginning with a '|' character, a different vulnerability than CVE-2017-17405. NOTE: situations with untrusted input may be highly unlikely.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1221-1, DLA-1222-1
NVD severityhigh (attack range: remote)
Debian Bugs884878, 884879

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby2.1 (PTS)jessie2.1.5-2+deb8u3vulnerable
jessie (security)2.1.5-2+deb8u1vulnerable
ruby2.3 (PTS)stretch (security), stretch2.3.3-1+deb9u2vulnerable
ruby2.5 (PTS)buster, sid2.5.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)(unfixed)high
ruby1.8sourcewheezy1.8.7.358-7.1+deb7u5highDLA-1222-1
ruby1.9.1source(unstable)(unfixed)high
ruby1.9.1sourcewheezy1.9.3.194-8.1+deb7u7highDLA-1221-1
ruby2.1source(unstable)(unfixed)high
ruby2.3source(unstable)(unfixed)high884879
ruby2.5source(unstable)2.5.0-1high884878

Notes

[stretch] - ruby2.3 <postponed> (Minor issue, can be fixed along in future DSA)
[jessie] - ruby2.1 <postponed> (Minor issue, can be fixed along in future DSA)
https://github.com/ruby/ruby/pull/1777
Fixed by: https://github.com/ruby/ruby/commit/e7464561b5151501beb356fc750d5dd1a88014f7

Search for package or bug name: Reporting problems