CVE-2017-18120

NameCVE-2017-18120
DescriptionA double-free bug in the read_gif function in gifread.c in gifsicle 1.90 allows a remote attacker to cause a denial-of-service attack or unspecified other impact via a maliciously crafted file, because last_name is mishandled, a different vulnerability than CVE-2017-1000421.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs878739, 881120

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gifsicle (PTS)wheezy1.67-1vulnerable
wheezy (security)1.67-1.1~deb7u1vulnerable
jessie1.86-1vulnerable
jessie (security)1.86-1+deb8u1vulnerable
stretch1.88-3vulnerable
stretch (security)1.88-3+deb9u1vulnerable
buster, sid1.91-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gifsiclesource(unstable)1.91-1medium878739, 881120

Notes

[wheezy] - gifsicle <ignored> (Minor issue)
https://github.com/kohler/gifsicle/issues/117
https://github.com/kohler/gifsicle/commit/118a46090c50829dc543179019e6140e1235f909

Search for package or bug name: Reporting problems