CVE-2017-18265

NameCVE-2017-18265
DescriptionProsody before 0.10.0 allows remote attackers to cause a denial of service (application crash), related to an incompatibility with certain versions of the LuaSocket library, such as the lua-socket package from Debian stretch. The attacker needs to trigger a stream error. A crash can be observed in, for example, the c2s module.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4198-1
Debian Bugs875829

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prosody (PTS)wheezy, wheezy (security)0.8.2-4+deb7u4fixed
jessie (security), jessie0.9.7-2+deb8u3fixed
stretch0.9.12-2vulnerable
stretch (security)0.9.12-2+deb9u1fixed
buster0.10.0-2fixed
sid0.10.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prosodysource(unstable)0.10.0-1875829
prosodysourcejessie(not affected)
prosodysourcestretch0.9.12-2+deb9u1DSA-4198-1
prosodysourcewheezy(not affected)

Notes

[jessie] - prosody <not-affected> (Only exploitable with a LuaSocket version not in jessie)
[wheezy] - prosody <not-affected> (Vulnerable code not present)
https://prosody.im/issues/issue/987

Search for package or bug name: Reporting problems