CVE-2017-18267

NameCVE-2017-18267
DescriptionThe FoFiType1C::cvtGlyph function in fofi/FoFiType1C.cc in Poppler through 0.64.0 allows remote attackers to cause a denial of service (infinite recursion) via a crafted PDF file, as demonstrated by pdftops.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1562-1
NVD severitymedium
Debian Bugs898357

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)jessie0.26.5-2+deb8u4vulnerable
jessie (security)0.26.5-2+deb8u13fixed
stretch (security), stretch0.48.0-2+deb9u2vulnerable
buster0.71.0-5fixed
bullseye, sid0.71.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.69.0-2898357
popplersourceexperimental0.65.0-1
popplersourcejessie0.26.5-2+deb8u5DLA-1562-1

Notes

[stretch] - poppler <no-dsa> (Minor issue)
[wheezy] - poppler <ignored> (Minor issue)
https://bugs.freedesktop.org/show_bug.cgi?id=104942
https://bugs.freedesktop.org/show_bug.cgi?id=103238
https://cgit.freedesktop.org/poppler/poppler/commit/?id=60b4fe65bc9dc9b82bbadf0be2e3781be796a13d

Search for package or bug name: Reporting problems