CVE-2017-18359

NameCVE-2017-18359
DescriptionPostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1653-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgis (PTS)jessie2.1.4+dfsg-3vulnerable
jessie (security)2.1.4+dfsg-3+deb8u1fixed
stretch2.3.1+dfsg-2vulnerable
buster, sid2.5.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgissource(unstable)2.3.3+dfsg-1low
postgissourcejessie2.1.4+dfsg-3+deb8u1mediumDLA-1653-1

Notes

[stretch] - postgis <no-dsa> (Minor issue)
https://trac.osgeo.org/postgis/ticket/3704
https://trac.osgeo.org/postgis/changeset/15444
https://trac.osgeo.org/postgis/changeset/15445

Search for package or bug name: Reporting problems