CVE-2017-18641

NameCVE-2017-18641
DescriptionIn LXC 2.0, many template scripts download code over cleartext HTTP, and omit a digital-signature check, before running it to bootstrap containers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lxc (PTS)jessie1:1.0.6-6+deb8u6vulnerable
jessie (security)1:1.0.6-6+deb8u2vulnerable
stretch1:2.0.7-2+deb9u2vulnerable
buster1:3.1.0+really3.0.3-8fixed
bullseye, sid1:3.1.0+really3.0.4-2fixed
lxc-templates (PTS)buster3.0.3-1vulnerable
bullseye, sid3.0.4-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lxcsource(unstable)1:3.0.3-1
lxc-templatessource(unstable)(unfixed)

Notes

LXC 3.0.2 split the templates out to separate lxc-templates.
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1661447
Some of the templates were switched to fetch the pacakges over HTTPS, cf.
https://github.com/lxc/lxc/pull/1371 for the lxc-fedora template.

Search for package or bug name: Reporting problems