DescriptionIt was discovered that websockets.c in LibVNCServer prior to 0.9.12 did not properly decode certain WebSocket frames. A malicious attacker could exploit this by sending specially crafted WebSocket frames to a server, causing a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)buster0.9.11+dfsg-1.3+deb10u4vulnerable
buster (security)0.9.11+dfsg-1.3+deb10u5vulnerable
sid, trixie, bookworm0.9.14+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[buster] - libvncserver <ignored> (Required change too invasive, minor issue)
[stretch] - libvncserver <ignored> (Required change too invasive, minor issue)

Search for package or bug name: Reporting problems