CVE-2017-2292

NameCVE-2017-2292
DescriptionVersions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs866711

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mcollective (PTS)wheezy2.0.0+dfsg-2vulnerable
sid, jessie2.6.0+dfsg-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mcollectivesource(unstable)(unfixed)high866711

Notes

https://puppet.com/security/cve/cve-2017-2292
https://github.com/puppetlabs/marionette-collective/commit/e0e741889f5adeb8f75387037106b0d28a9099b0

Search for package or bug name: Reporting problems