CVE-2017-2299

NameCVE-2017-2299
DescriptionVersions of the puppetlabs-apache module prior to 1.11.1 and 2.1.0 make it very easy to accidentally misconfigure TLS trust. If you specify the `ssl_ca` parameter but do not specify the `ssl_certs_dir` parameter, a default will be provided for the `ssl_certs_dir` that will trust certificates from any of the system-trusted certificate authorities. This did not affect FreeBSD.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs875983

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet-module-puppetlabs-apache (PTS)jessie1.1.1-1vulnerable
stretch1.10.0-1vulnerable
buster, sid3.1.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppet-module-puppetlabs-apachesource(unstable)(unfixed)medium875983

Notes

[stretch] - puppet-module-puppetlabs-apache <no-dsa> (Minor issue)
[jessie] - puppet-module-puppetlabs-apache <no-dsa> (Minor issue)
https://puppet.com/security/cve/CVE-2017-2299
https://github.com/puppetlabs/puppetlabs-apache/commit/7bb35c2293c12ce52329a4391fe1f20389efef06

Search for package or bug name: Reporting problems