CVE-2017-2518

NameCVE-2017-2518
DescriptionAn issue was discovered in certain Apple products. iOS before 10.3.2 is affected. macOS before 10.12.5 is affected. tvOS before 10.2.1 is affected. watchOS before 3.2.2 is affected. The issue involves the "SQLite" component. It allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a crafted SQL statement.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite3 (PTS)wheezy3.7.13-1+deb7u2vulnerable
wheezy (security)3.7.13-1+deb7u4vulnerable
jessie3.8.7.1-1+deb8u2vulnerable
jessie (security)3.8.7.1-1+deb8u1vulnerable
stretch3.16.2-5fixed
buster, sid3.21.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlite3source(unstable)3.15.2-1high

Notes

[wheezy] - sqlite3 <no-dsa> (Minor issue)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=199
https://clusterfuzz-external.appspot.com/testcase?key=4603622180519936
Fixed by: https://www.sqlite.org/src/info/0a98c8d76ac86412

Search for package or bug name: Reporting problems