CVE-2017-2520

NameCVE-2017-2520
DescriptionAn issue was discovered in certain Apple products. iOS before 10.3.2 is affected. macOS before 10.12.5 is affected. tvOS before 10.2.1 is affected. watchOS before 3.2.2 is affected. The issue involves the "SQLite" component. It allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a crafted SQL statement.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1633-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite (PTS)buster2.8.17-15fixed
buster (security)2.8.17-15+deb10u1fixed
sqlite3 (PTS)buster3.27.2-3+deb10u1fixed
buster (security)3.27.2-3+deb10u2fixed
bullseye3.34.1-3fixed
bookworm3.40.1-2fixed
trixie, sid3.45.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlitesource(unstable)(not affected)
sqlite3sourcewheezy(not affected)
sqlite3sourcejessie3.8.7.1-1+deb8u4DLA-1633-1
sqlite3source(unstable)3.16.2-1

Notes

[wheezy] - sqlite3 <not-affected> (Vulnerable code not present)
- sqlite <not-affected> (Vulnerable code not present)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=384
https://clusterfuzz-external.appspot.com/testcase?key=5694101458518016
Fixed by: https://www.sqlite.org/src/info/2dc7eeb5b4d2eaf1

Search for package or bug name: Reporting problems