CVE-2017-2661

NameCVE-2017-2661
DescriptionClusterLabs pcs before version 0.9.157 is vulnerable to a cross-site scripting vulnerability due to improper validation of Node name field when creating new cluster or adding existing cluster.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs858379

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcs (PTS)buster0.10.1-2fixed
buster (security)0.10.1-2+deb10u1fixed
bullseye (security), bullseye0.10.8-1+deb11u1fixed
bookworm0.11.5-1+deb12u1fixed
sid, trixie0.11.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcssource(unstable)0.9.155+dfsg-2858379

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1428948
https://github.com/ClusterLabs/pcs/commit/1874a769b5720ae5430f10c6cedd234430bc703f
https://www.openwall.com/lists/oss-security/2017/03/23/2

Search for package or bug name: Reporting problems