CVE-2017-3257

NameCVE-2017-3257
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: InnoDB). Supported versions that are affected are 5.6.34 and earlier5.7.16 and earlier. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS v3.0 Base Score 6.5 (Availability impacts).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3770-1
NVD severitymedium (attack range: remote)
Debian Bugs851234, 851235, 851755, 851759

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.30-0+deb8u2fixed
jessie (security)10.0.32-0+deb8u1fixed
mariadb-10.1 (PTS)stretch (security), stretch10.1.26-0+deb9u1fixed
buster10.1.26-1fixed
sid10.1.28-1fixed
mysql-5.5 (PTS)wheezy5.5.47-0+deb7u1fixed
wheezy (security)5.5.58-0+deb7u1fixed
jessie5.5.55-0+deb8u1fixed
jessie (security)5.5.58-0+deb8u1fixed
mysql-5.7 (PTS)sid5.7.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)(unfixed)medium851755
mariadb-10.0sourcejessie10.0.29-0+deb8u1mediumDSA-3770-1
mariadb-10.1source(unstable)10.1.21-1medium851759
mysql-5.5source(unstable)(not affected)
mysql-5.6source(unstable)5.6.35-1medium851234
mysql-5.7source(unstable)5.7.17-1medium851235

Notes

- mysql-5.5 <not-affected> (Only affects MySQL 5.6 and 5.7)

Search for package or bug name: Reporting problems