CVE-2017-3305

NameCVE-2017-3305
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: C API). Supported versions that are affected are 5.5.54 and earlier and 5.6.35 and earlier. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all MySQL Server accessible data. CVSS 3.0 Base Score 5.3 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N). NOTE: the previous information is from the April 2017 CPU. Oracle has not commented on third-party claims that this issue allows man-in-the-middle attackers to hijack the authentication of users by leveraging incorrect ordering of security parameter verification in a client, aka, "The Riddle".
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-916-1, DSA-3834-1
NVD severitymedium (attack range: remote)
Debian Bugs860544

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-5.5 (PTS)wheezy5.5.47-0+deb7u1vulnerable
wheezy (security)5.5.55-0+deb7u1fixed
jessie (security), jessie5.5.55-0+deb8u1fixed
mysql-5.7 (PTS)sid5.7.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-5.5source(unstable)(unfixed)medium860544
mysql-5.5sourcejessie5.5.55-0+deb8u1mediumDSA-3834-1
mysql-5.5sourcewheezy5.5.55-0+deb7u1mediumDLA-916-1
mysql-5.7source(unstable)(not affected)

Notes

- mysql-5.7 <not-affected> (Fixed before the initial release to Debian)
The issue arises because of an improper fix for the issue known under
the name BACKRONYM. The CVE CVE-2015-3152 though is explicitly only
assigned for MariaDB and Percona, thus Oracle MySQL products are not
tracked below that CVE. Later, Oracle tried to address the corresonding
issue as well in 5.5 (in 5.5.49) and 5.6 (5.6.30) series resulting in
opening CVE-2017-3305.
Cf. https://bugzilla.redhat.com/show_bug.cgi?id=1217506#c22
http://www.openwall.com/lists/oss-security/2017/03/17/4

Search for package or bug name: Reporting problems