CVE-2017-3308

NameCVE-2017-3308
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: DML). Supported versions that are affected are 5.5.54 and earlier, 5.6.35 and earlier and 5.7.17 and earlier. Easily "exploitable" vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. While the vulnerability is in MySQL Server, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 7.7 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-916-1, DSA-3834-1, DSA-3944-1
NVD severitymedium (attack range: remote)
Debian Bugs860544, 860547

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.30-0+deb8u2vulnerable
jessie (security)10.0.32-0+deb8u1fixed
mariadb-10.1 (PTS)stretch10.1.23-9+deb9u1fixed
buster10.1.24-6fixed
sid10.1.25-1fixed
mysql-5.5 (PTS)wheezy5.5.47-0+deb7u1vulnerable
wheezy (security)5.5.57-0+deb7u1fixed
jessie5.5.55-0+deb8u1fixed
jessie (security)5.5.57-0+deb8u1fixed
mysql-5.7 (PTS)sid5.7.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)(unfixed)medium
mariadb-10.0sourcejessie10.0.32-0+deb8u1mediumDSA-3944-1
mariadb-10.1source(unstable)10.1.23-1medium
mysql-5.5source(unstable)(unfixed)medium860544
mysql-5.5sourcejessie5.5.55-0+deb8u1mediumDSA-3834-1
mysql-5.5sourcewheezy5.5.55-0+deb7u1mediumDLA-916-1
mysql-5.7source(unstable)5.7.18-1medium860547

Search for package or bug name: Reporting problems