CVE-2017-3648

NameCVE-2017-3648
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Charsets). Supported versions that are affected are 5.5.56 and earlier, 5.6.36 and earlier and 5.7.18 and earlier. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1043-1, DSA-3922-1
NVD severitymedium (attack range: remote)
Debian Bugs868788, 868798

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-5.5 (PTS)wheezy5.5.47-0+deb7u1vulnerable
wheezy (security)5.5.59-0+deb7u1fixed
jessie5.5.58-0+deb8u1fixed
jessie (security)5.5.59-0+deb8u1fixed
mysql-5.7 (PTS)sid5.7.21-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-5.5source(unstable)(unfixed)medium868788
mysql-5.5sourcejessie5.5.57-0+deb8u1mediumDSA-3922-1
mysql-5.5sourcewheezy5.5.57-0+deb7u1mediumDLA-1043-1
mysql-5.7source(unstable)5.7.20-1medium868798

Search for package or bug name: Reporting problems