CVE-2017-3653

NameCVE-2017-3653
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: DDL). Supported versions that are affected are 5.5.56 and earlier, 5.6.36 and earlier and 5.7.18 and earlier. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data. CVSS 3.0 Base Score 3.1 (Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1043-1, DSA-3922-1, DSA-3944-1, DSA-3955-1
NVD severitylow (attack range: remote)
Debian Bugs868788, 868798, 884065

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.30-0+deb8u2vulnerable
jessie (security)10.0.32-0+deb8u1fixed
mariadb-10.1 (PTS)stretch (security), stretch10.1.26-0+deb9u1fixed
buster, sid1:10.1.29-6fixed
mariadb-10.2 (PTS)sid10.2.7-1vulnerable
mysql-5.5 (PTS)wheezy5.5.47-0+deb7u1vulnerable
wheezy (security)5.5.58-0+deb7u1fixed
jessie (security), jessie5.5.58-0+deb8u1fixed
mysql-5.7 (PTS)sid5.7.20-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)(unfixed)low
mariadb-10.0sourcejessie10.0.32-0+deb8u1lowDSA-3944-1
mariadb-10.1source(unstable)10.1.26-1low
mariadb-10.1sourcestretch10.1.26-0+deb9u1lowDSA-3955-1
mariadb-10.2source(unstable)(unfixed)low884065
mysql-5.5source(unstable)(unfixed)low868788
mysql-5.5sourcejessie5.5.57-0+deb8u1lowDSA-3922-1
mysql-5.5sourcewheezy5.5.57-0+deb7u1lowDLA-1043-1
mysql-5.7source(unstable)(unfixed)low868798

Search for package or bug name: Reporting problems