CVE-2017-5195

NameCVE-2017-5195
DescriptionIrssi 0.8.17 before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a crafted ANSI x8 color code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs850403

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)jessie (security), jessie0.8.17-1+deb8u5fixed
stretch (security), stretch1.0.7-1~deb9u1fixed
buster1.2.0-2fixed
bullseye, sid1.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisource(unstable)0.8.21-1850403
irssisourcejessie0.8.17-1+deb8u3
irssisourcewheezy(not affected)

Notes

[wheezy] - irssi <not-affected> (Affects only 0.8.17 and later)
http://www.openwall.com/lists/oss-security/2017/01/05/2
https://github.com/irssi/irssi/commit/6c6c42e3d1b49d90aacc0b67f8540471cae02a1d
https://irssi.org/security/irssi_sa_2017_01.txt

Search for package or bug name: Reporting problems