CVE-2017-5356

NameCVE-2017-5356
DescriptionIrssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1217-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)stretch (security), stretch1.0.7-1~deb9u1fixed
buster1.2.0-2+deb10u1fixed
bookworm, sid, bullseye1.2.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisourcewheezy0.8.15-5+deb7u4DLA-1217-1
irssisourcejessie0.8.17-1+deb8u3
irssisource(unstable)0.8.21-1low

Notes

https://github.com/irssi/irssi/commit/6c6c42e3d1b49d90aacc0b67f8540471cae02a1d
https://blog.fuzzing-project.org/55-Fuzzing-Irssi-with-Perl-Scripts.html
https://irssi.org/security/irssi_sa_2017_01.txt

Search for package or bug name: Reporting problems