CVE-2017-5666

NameCVE-2017-5666
DescriptionThe free_options function in options_manager.c in mp3splt 2.6.2 allows remote attackers to cause a denial of service (invalid free and crash) via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs854278

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mp3splt (PTS)wheezy, jessie2.4.2-2vulnerable
buster, sid2.6.2+20170630-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mp3spltsource(unstable)(unfixed)medium854278

Notes

[jessie] - mp3splt <no-dsa> (Minor issue)
[wheezy] - mp3splt <no-dsa> (Minor issue)
https://blogs.gentoo.org/ago/2017/01/29/mp3splt-invalid-free-in-free_options-options_manager-c
https://sourceforge.net/p/mp3splt/bugs/209/

Search for package or bug name: Reporting problems