CVE-2017-5884

NameCVE-2017-5884
Descriptiongtk-vnc before 0.7.0 does not properly check boundaries of subrectangle-containing tiles, which allows remote servers to execute arbitrary code via the src x, y coordinates in a crafted (1) rre, (2) hextile, or (3) copyrect tile.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-831-1
NVD severitymedium (attack range: remote)
Debian Bugs854450

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gtk-vnc (PTS)wheezy0.5.0-3.1vulnerable
wheezy (security)0.5.0-3.1+deb7u1fixed
jessie0.5.3-1.3vulnerable
buster, sid, stretch0.6.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gtk-vncsource(unstable)0.6.0-3medium854450
gtk-vncsourcewheezy0.5.0-3.1+deb7u1mediumDLA-831-1

Notes

[jessie] - gtk-vnc <no-dsa> (Minor issue)
Scope of the CVE is all of https://bugzilla.gnome.org/show_bug.cgi?id=778048#c1
http://openwall.com/lists/oss-security/2017/02/05/5

Search for package or bug name: Reporting problems